Home > Cannot Open > Cannot Open /var/lib/alsa/asound.state For Writing Permission Denied

Cannot Open /var/lib/alsa/asound.state For Writing Permission Denied

This what I did and maybe someone is helped with this. # Turning on manually downmix(not always needed): Code: sudo nano .xbmc/userdata/advancedsettings.xml and enter Code:

# You've turned me on to a whole new terminal existence I was unaware of. [email protected] ~ $ alsactl store 0 HDA intel alsactl: save_state:1532: Cannot open /var/lib/alsa/asound.state for writing: Permission denied. I changed one method signature and broke 25,000 other classes. this contact form

Not saving my alsamixer settings drove me nuts: extremly low volume and with the mic's on full open; a lot of audio snow. I'll let you know. Reason: added sudo tredegar View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by tredegar 08-01-2011, 07:56 AM #5 bustertech LQ Newbie When in alsamixer and I hit F5, I get three options; "default", "0 HDA intel" and "enter soundcard" Still, nothing is storing and I'm having to go into alsamixer every time

This stores your mixer settings in /var/lib/alsa/asound.state for later use. 4.) From The Xubuntu/Xfce menu, go to Settings and open Sessions and Startup. Most helpful thread, solved my issues but the following command will provide all users r/w access to the file (correcting the above) sudo chmod 666 /var/lib/alsa/asound.state Matt ProDigitOctober 27th, 2009, 12:19 I'm wondering why alsa is so hard to get properly installed compared to the easy OSS.tcz. « Last Edit: September 21, 2013, 05:27:29 PM by LinuxUser01 » Logged Misalf Hero Member

This causes the "alsactl restore" command to automatically run when you start your computer. Antonym for Nourish Why there are no approximation algorithms for SAT and other decision problems? When I type 'sudo alsactl store' I get: E-core/util.c: home directory /home/yuka not ours. I'm going to click "Problem Solved" instead of "I Still Need an Answer" because even though this is a work-around and not a true solution, it is sufficient for my needs,

sound alsa share|improve this question asked Jul 14 '15 at 11:02 senthor 214 Apparently, your user (or whoever rc.local is executed as) has no root privileges. –CL. Thanks again for your help. I also revised the bootlocal.sh: #!/bin/sh/usr/local/etc/init.d/alsasound start/usr/local/sbin/alsactl restore &These procedures that i have done still hasn't changed the way i have to get the sound working from a boot/reboot. imp source Please visit this page to clear all LQ-related cookies.

Compare elements iteratively Why are LEDs in my home unaffected by voltage drop? Some of the controls don't work like the view control. Blog Download Wiki Bugtracker Search Help Create Account Login UbuntuCommunityAsk!DeveloperDesignDiscourseHardwareInsightsJujuShopMore ›AppsHelpForumLaunchpadMAASCanonical current community chat Ask Ubuntu Ask Ubuntu Meta your communities Sign up or log in to customize your list. shiny_spoon Linux - Software 6 11-02-2003 12:36 PM All times are GMT -5.

more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed http://askubuntu.com/questions/648248/aslactl-storing-restoring-issues Hello There, Guest! find quote japhule Junior Member Posts: 19 Joined: Oct 2007 Reputation: 0 2010-10-23 19:05 Post: #3 vikjon0 Wrote:Yes, I had that. Logged Download a copy and keep it handy: Core book ;) Print Pages: [1] 2 3 4 Go Up « previous next » Tiny Core Linux » Tiny Core Extensions »

Offline Pages: 1 Index »Help & Support (Crunchbang 11 "Waldorf") »[Resolved] alsa restart fails Board footer Jump to News & Announcements Feedback & Suggestions Help & Support (Crunchbang 11 "Waldorf") Help weblink Having a problem logging in? Not sure if i should delete the /var/lib/alsa/asound.state subdirectory/files and just copy it to /usr/local/etc/asound.state then delete the /var/lib/alsa/asound.state unlock file from backup and add the new directory and unlocked file It worked for me! ;) johnmsmithFebruary 1st, 2010, 08:01 AMAfter upgrading to 9.10 from 9.04 I experienced this "mute" problem.

Note that registered members see fewer ads, and ContentLink is completely disabled once you log in. When I run it as normal user, it complains about not being able to store the file in /var/lib/alsa When I run it as root with sudo, it complains about not Edit bug mail Other bug subscribers Subscribe someone else • Take the tour • Read the guide © 2004-2016 CanonicalLtd. • Terms of use • Contact Launchpad Support • Blog navigate here ElviswindNovember 14th, 2009, 05:20 AMI'm now running Xubuntu 9.10 and had the sound muting problem, but I was also suffering from crappy sound . . .

I have to turn the mute off and turn up the master volume every time I reboot. Notices Welcome to LinuxQuestions.org, a friendly and active Linux Community. Logged Misalf Hero Member Posts: 1146 Re: alsa sound not loading properly « Reply #4 on: September 21, 2013, 04:34:12 PM » ~/.X.d/ is the 'autostart' folder.Any file in there will

Logged LinuxUser01 Full Member Posts: 111 Re: alsa sound not loading properly « Reply #3 on: September 21, 2013, 04:32:14 PM » I have tried different features in emeIFM2 to get

Forum Menu Index User list Rules Search Register Login You are not logged in. Only some soundcards can handle alsa and OSS at the same time (hardware mixing) without problems. find quote Locutusweb Junior Member Posts: 27 Joined: Aug 2010 Reputation: 0 2010-10-24 20:15 Post: #5 In Dharma 2 I didn't even got the error japhule describes. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

MrClearPoreJuly 3rd, 2008, 05:10 PMYes. What crime would be illegal to uncover in medieval Europe? I have tried typing in command "alsactl store" to only get: alsactl: state_lock:121: file /var/lib/alsa/asound.state lock error: File existsalsactl: state_lock:121: file /var/lib/alsa/asound.state unlock error: File existsThe thing is that its suppose his comment is here Logged Download a copy and keep it handy: Core book ;) LinuxUser01 Full Member Posts: 111 Re: alsa sound not loading properly « Reply #6 on: September 21, 2013, 05:21:39 PM

Strip the part from rc.local Save alsa-config to file: alsactl --file ~/.asound.state store Edit /etc/init.d/shairport-sync by adding /usr/bin/sudo /usr/sbin/alsactl --file /home/[username]/.asound.state restore after do_start() { Now, everytime shairport-sync is started, volumes Not sure if I found a good solution, but I think removing pulseaudio is a workaround. Visit the following links: Site Howto | Site FAQ | Sitemap | Register Now If you have any problems with the registration process or your account login, please contact us. When you get "permission denied" it usually means you need to be root, so try Code: sudo alsactl store once you have adjusted your mutes and volumes with alsamixer.

If you don't have a root terminal menu selection, then open a regular terminal and type: sudo gnome-terminal. Can I hint the optimizer by giving the range of an integer? I've had the same problem in debian sid, so I ran alsactl store http://linux.derkeiler.com/Mailing-Lists/Debian/2005-06/1356.html Hope it helps. [email protected] ~ $ alsactl store HDA alsactl: save_state:1519: Cannot find soundcard 'HDA'...