Home > Cannot Open > Cannot Open /usr/lib/httpd/build/config_vars.mk

Cannot Open /usr/lib/httpd/build/config_vars.mk

How to gain confidence with new "big" bike? cannot open /httpd/build/config_vars.mk: No such file or directory at /usr/sbin/apxs line 201. See: http://lists.centos.org/pipermail/centos-devel/2008-August/003107.html http://bugs.centos.org/view.php?id=3084 (3) Due to a recent renumbering of the entries in the CentOS mailing lists, the URL in Note 7563 above is no longer valid. Not the answer you're looking for? this contact form

In this layout the build-directory is under "/usr/local/share/apache2/build" and the prefix is "/usr/local/" If I change that to the right path (/usr/local/share/apache2/build/" it works and I can compile php. Did you compile it yourself or is it from a binary distribution? See http://lists.centos.org/pipermail/centos-devel/2008-June/004808.html ~0007541 timverhoeven (developer) 2008-07-01 17:19 Closing bug. Report a bug This report contains Public information Edit Everyone can see this information. http://serverfault.com/questions/646873/how-to-configure-lib-path-for-apache-utilities

current community blog chat Server Fault Meta Server Fault your communities Sign up or log in to customize your list. Got a problem during make... & ./configure [...] checking whether to enable maintainer-specific portions of Makefiles... When i try: lfuka@dhcp-4-207:/opt/EWS/3.0.0/jws-3.0/httpd/sbin$ ./apxs -q CC Use of uninitialized value $ENV{"EWS_HOME"} in concatenation (.) or string at ./apxs line 38.

mbacou referenced this issue in jeroenooms/opencpu May 21, 2016 Closed CentOS with httpd24 #188 Sign up for free to join this conversation on GitHub. Navegación de publicación instalando hydrogen 0.9.4usr/bin/ld: skipping incompatible /usr/lib/libz.so when searching for -lz Deja un comentario Cancelar respuesta Tu dirección de correo electrónico no será publicada. Browse other questions tagged apache-2.2 redhat or ask your own question. Please Note: this e-mail address is only for reporting problems with ASF Bugzilla.

up vote 1 down vote favorite I juste installed apxs bin with the httpd24-httpd-devel-2.4.6-16.el6.x86_64 package. I've fixed support/apxs.in on my system, sort of. cannot open /httpd/lib/build/config_vars.mk: Adresář nebo soubor neexistuje at ./apxs line 214. https://lists.centos.org/pipermail/centos-devel/2008-June/002955.html rapache owner jeffreyhorner commented Aug 4, 2015 That's really strange.

etpoole60 New Member HowtoForge Supporter I was going throught the steps and go to suPHP, in particular: cd /tmp wget http://suphp.org/download/suphp-0.7.1.tar.gz tar xvfz suphp-0.7.1.tar.gz cd suphp-0.7.1/ ./configure --prefix=/usr --sysconfdir=/etc --with-apr=/usr/bin/apr-1-config --with-apxs=/usr/sbin/apxs I just entered: system-config-securitylevel And SELinux shows as disabled. This resets $PATH to the default. But when i try to make "make install" I get the following: /usr/local/sbin/apxs -i -a -n php4 libphp4.la /usr/local/build/instdso.sh SH_LIBTOOL='/usr/local/build/libtool' libphp4.la /usr/local/libexec sh: /usr/local/build/instdso.sh: No such file or directory apxs:Error: Command

This way only the i386 version gets installed, while pkg-config on a 64bit machine will look in /usr/lib64/pkgconfig for the apr-1.pc package. https://bugzilla.redhat.com/show_bug.cgi?id=1180563 more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed In line 69: get_config_vars("$prefix/build/config_vars.mk",\%config_vars); I am using the GNU layout. Carl George (carl.george) wrote on 2015-08-03: #5 httpd24u-2.4.16-2.ius will move to the stable repositories during tonight's automation.

I need it to compile PHP with Apache module. weblink Mark as duplicate Convert to a question Link a related branch Link to CVE You are not directly subscribed to this bug's notifications. Give me some time to sort out how to correctly patch this so the symlinks aren't needed. rapache collaborator jeroenooms commented Aug 4, 2015 You'll still need to manually configure, make, make install because the rapache rpm scripts all assume apache is in /etc/httpd which is not the

Can you check if apache 2.4 includes apxs or apxs2? Custom Object as Standard Controller: Plural Or Singular Developer does not see priority in git Development Workflow being followed Why did the best potions master have greasy hair? Why did Michael Corleone not forgive his brother Fredo? http://scriptkeeper.net/cannot-open/cannot-open-config-file-vsftpd-conf.html But if you make sure there is only a single version of httpd installed on the machine, the configure script will probably pick it up so you don't have to manually

Reload to refresh your session. mbacou commented Aug 4, 2015 Thanks Jeroen, yeh I think that's the problem. There was already bug for standard CentOS/RedHat rpm which was fixed.

mbacou commented Aug 4, 2015 This is apache 2.4, and I removed all existing rapache packages. $ yum list *httpd24* Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile *

Affecting: IUS Community Project Filed here by: Mason Malone When: 2015-07-27 Confirmed: 2015-07-27 Started work: 2015-07-27 Completed: 2015-08-03 Target Distribution Baltix BOSS Juju Charms Collection Elbuntu Guadalinex Guadalinex Edu Kiwi Linux rapache collaborator jeroenooms commented Aug 4, 2015 I think you need to yum install httpd24-apr-devel httpd24-httpd-devel mbacou commented Aug 4, 2015 OK, nearly there, but I seem to have another link It uses pkg-config to get the libdir of the apr-1 package, as follows: my $libdir = `pkg-config --variable=libdir apr-1`; This returns an empty string if you have apr15u-devel installed, because its mbacou commented Aug 4, 2015 That said, I didn't build apache 2.4 manually, just a standard yum install from EPEL.

It's been fixed upstream and the patched version will be made available[1]. configure: error: no - APXS refers to an old version of Apache Unable to locate /mod_dav.h configure ܤƤޤä ȤƤ /usr/lib64/pkgconfig apr-1 ե뤬¸ߤʤᡢ꤬ɤ᤺ǻǤޤäƤޤ äơ/usr/lib/pkgconfig/apr-1.pc /usr/lib64/pkgconfig/apr-1.pc ˥ԡ ơԡΤ򳫤ơ饤֥ѥ /lib ʲսlib64 Carl George (carl.george) wrote on 2015-07-27: #3 I believe I have fixed these issues. http://scriptkeeper.net/cannot-open/cannot-open-config-file-usr-local-ssl-openssl-cnf.html I'm trying to build Subversion, and its configuration script fails due to this bug.

So please take this issue to either the mailing lists or the forums, if you cannot figure it out yourself. ~0008117 mickh (reporter) 2008-10-11 12:35 OK, well not sure if this Hyper Derivative definition. more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science I do not know how to access that variable or how I should do it right, because I am not so familiar with the code-structurof apache.

This module has been compiled against httpd-devel with apache 2.2, so you can't load this module in 2.4. configure: error: failed to recognize APR_INT64_T_FMT on this platform ʤܤޤġ ƺäȤˡˤĤƤξ Web õƤΤҥåȤʤȡ Ĥ󡢤δĶΤϡġʶ orz Ĵ configure ξ嵭顼åФƤդ򤵤ȡ include APR_INT64_T_FMT ΥƥȤ򤷤ƤޤġĤäơޤ apr 衣 Ȥꤢapr.h ȼΤ褦˽񤫤Ƥޤ #if defined(__i386__) #include "apr-i386.h" No, create an account now. We recommend upgrading to the latest Safari, Google Chrome, or Firefox.

It doesn't look like this is fixed in CVS either (looking via ViewCVS at http://cvs.apache.org/viewcvs.cgi/httpd-2.0/support/apxs.in, which seems to be at version 1.37). rapache collaborator jeroenooms commented Aug 4, 2015 No you need to build from source: wget https://github.com/jeffreyhorner/rapache/archive/v1.2.7.tar.gz tar xzvf v1.2.7.tar.gz cd rapache-1.2.7 ./configure make sudo make install mbacou commented Aug 4, 2015 Reload to refresh your session. 褦Ȥ ֥ȥå ̵֥ 夦.jp Programmable maiden Tech side goto OTA side >> <[Linux]ATOMCentOS5.2ͥ...|[Linux] shutdown -r now ...> 2008-10-19 64bit linux Subversion ѥǤʤƻ˴ mbacou commented Aug 4, 2015 Removed httpd-devel and installed httpd24-devel, tried to rebuild. $ rpmbuild -ba ~/rpmbuild/SPECS/rapache.spec error: Failed build dependencies: httpd-devel is needed by rapache-1.2.7-rpm0.x86_64 libapreq2-devel is needed by rapache-1.2.7-rpm0.x86_64

Same goes for the 64bit apr-util-devel package.