Home > Cannot Mount > Error 17 Cannot Mount Selected Partition Grub

Error 17 Cannot Mount Selected Partition Grub


And added menuentry "Windows Vista" { set root='(hd0,1)' chainloader +1 } between ### BEGIN /etc/grub.d/40_custom ### and ### END /etc/grub.d/40_custom ### And don't forget to save the file. Register now! A big thanks in advance. There are six boot options and none of them work they all come with this error. "Error 17. Check This Out

Please, include all the scripts under /etc/grub.d. –Braiam Apr 10 '14 at 16:14 add a comment| 2 Answers 2 active oldest votes up vote 4 down vote accepted I tried using The /boot partition is on /dev/sda1 and /dev/sdb1 which, I thought would be (hd0,0) and (hd1,0). What you describe sounds like it shoulda worked... 12-17-2007, 06:01 AM #3 Istanbul_Lfc Registered Member Join Date: Oct 2007 Location: Liverpool, UK Posts: 193 OS: Windows 7, We Acted. https://www.suse.com/support/kb/doc?id=7010670

Error 17 Cannot Mount Selected Partition Grub

Last edited by oldstutz (2010-07-26 02:55:09) Offline #5 2010-07-26 03:05:19 itsbrad212 Member From: Chicago, USA Registered: 2010-01-23 Posts: 1,848 Re: [SOLVED] Error 17: cannot mount selected partition I remember I got But why is grub seeing /dev/sdb as (hd1,0) in some places and as (hd3,0) (I'm assuming) in others? Teenage daughter refusing to go to school more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology

Thank you all for your help it is much appreciated. SUSE Technical Support Handbook Update Advisories Support FAQ Open an Incident Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access. is this Grub4DOS? –quack quixote Apr 15 '10 at 15:58 i am using grub in fedora 12. Grub Command Line You may have to register before you can post: click the register link above to proceed.

grub2 share|improve this question edited May 5 '14 at 22:54 Christopher Kyle Horton 8,9811260127 asked Dec 4 '10 at 15:16 Searock 1842721 thanks for the update - investigating what Error 17 Cannot Mount Selected Partition Redhat This is what I have tried. I'd try again. https://www.novell.com/support/kb/doc.php?id=7010670 With both dries plugged in.

Unfortunately I don't know how. Grub Rescue After updating the grub I opened grub.cfg using sudo gedit /boot/grub/grub.cfg command. Thanks! Top AlanBartlett Forum Moderator Posts: 9298 Joined: 2007/10/22 11:30:09 Location: ~/Earth/UK/England/Suffolk Contact: Contact AlanBartlett Website Re: [SOLVED] Problems with RAID 1 GRUB setup Quote Postby AlanBartlett » 2011/09/23 19:38:49 Thank you

Error 17 Cannot Mount Selected Partition Redhat

Both HDDs have the same partition layout, the partitions are properly combined in 8 RAID devices.Code: Select all
== BEGIN df -h ==
Filesystem Size Used http://askubuntu.com/questions/16167/how-do-i-get-the-grub-menu-to-show-when-starting-my-dual-boot-system Did a thief think he could conceal his identity from security cameras by putting lemon juice on his face? Error 17 Cannot Mount Selected Partition Grub Boot to Live CD 3. Grub Filesystem Type Unknown Partition Type 0x83 Can you provide me the output of following command: cat /proc/mdstat www.24x7servermanagement.com Server Management, Server Security, Server Monitoring.

Sorry for all the questions. his comment is here Ubuntu Kernel - Generic Ubuntu Safe Mode Windows XP Home etc. the example above is what i changed it to. partitioning mount ntfs grub setup share|improve this question edited Apr 15 '10 at 16:05 quack quixote 31.4k1068114 asked Apr 15 '10 at 15:57 MA1 53921129 what version of grub Cannot Mount Selected Partition Linux

Not the answer you're looking for? Now some of thesd like Easeus Partition Manager and Avira work fine but Ubuntu and PCLinuxOS do not. Change root (hd0) to the desired value (e.g. this contact form Does it boot up and run?

I'm not sure how the mapping to 0xff or hd32 actually work, but in my case it says that it is unable to mount the selected partition. For this I followed this tutorial that works perfectly on CentOS 5.x:http://wiki.centos.org/HowTos/SoftwareRAIDonCentOS5But saddly this is not the case if I try to do the same thing on CentOS 6.If I try At least that's how I understand it Error 17 looks to me like GRUB doesn't recognize the disk formatting as one it can use.

sdb1 is my root partition.

In one little line that's not very obvious, it'll say something like "GRUB will install to ..." and there will be a little tiny box saying "hd0". We recently had /dev/sdb fail on this RAID and it had to be replaced. Trying to get .ISO's to boot from Grub4Dos Started by r6xual , Oct 04 2011 03:16 PM Page 1 of 2 1 2 Next Please log in to reply 25 replies Now the problem is that my machine directly boots Ubuntu and even does not show me grub menu.

Let us know so we can fix it. separate /boot partition, respectively) to cover all the bases.Code: Select all# grub

grub> find /boot/grub/grub.conf
find /boot/grub/grub.conf

grub> find /grub/grub.conf
find /grub/grub.conf
http://scriptkeeper.net/cannot-mount/mount-partition-ubuntu-command-line.html Thanks for your help. –Searock Dec 4 '10 at 16:10 it definitely looks like grub is looking for some external media.Did you mount /boot on a separate partition? –tinhed

Looked like a successful installation, but when I restarted grub was loading and quit part way with the Error 17: cannot mount selected partition... This is what I'd do with my admittedly limited experience. up vote 3 down vote The first part is that the GRUB menu is there it just hides but the left-shift key during boot brings it up (as described in How Environment SUSE Linux Enterprise Server 11 Service Pack 1SUSE Linux Enterprise Server 11 Service Pack 2 Situation After an online update grub fails with:Error 17: Cannot mount selected partition Resolution Solution:

Check the changes on the screen for correctness and press "b" to boot.Once the system is online, please adjust /boot/grub/menu.lst and change all root (hd0) entries to their correct values. So i have installed openSUSE 10.3 and it has allowed me to save GRUB to the slave without problem. Even grub is showing that stage one is installed on (hd0,0) and (hd1,0), yet root (hd1,0) does not boot but root (hd3,0) does. I still don't know how to explain: Code: grub> find /grub/stage1 find /grub/stage1 (hd0,0) (hd1,0) This has puzzled me all weekend.

On systems running SLES11SP2 update perl-Bootloader to version or later. The issue is resolved. Go to the previous site to read in my language Stay here and read in English × Give Us Feedback Got some feedback about the website? And my understanding of how GRUB works is not exactly flawless.

On 1941 Dec 7, could Japan have destroyed the Panama Canal instead of Pearl Harbor in a surprise attack? Adverb for "syntax" How can a Cleric be proficient in warhammers? To start viewing messages, select the forum that you want to visit from the selection below. Found linux image: /boot/vmlinuz-2.6.35-22-generic Found initrd image: /boot/initrd.img-2.6.35-22-generic Found memtest86+ image: /boot/memtest86+.bin ls: cannot access /media/BC54B2C654B282A6/boot Boot: No such file or directory done sudo os-prober ls: cannot access /media/BC54B2C654B282A6/boot Boot: No