Home > Cannot Locate > Cannot Locate Xml/sax/parserfactory.pm

Cannot Locate Xml/sax/parserfactory.pm

What happens if you a) pm-uninstall -fn XML::SAX b) make pure_install and c) see perl -MXML::SAX can load XML::SAX? yes checking for stdlib.h... a.out checking for suffix of executables... Install both at the same time. have a peek here

make[1]: Entering directory `/var/tmp/portage/app-text/docbook2X-0.8.8-r2/work/docbook2X-0.8.8' make[1]: Nothing to be done for `all-am'. ok All tests successful. BEGIN failed--compilation aborted at /usr3/richardt/XML-SAX-0.12/blib/lib/XML/SA X/PurePerl.pm line 20. cpanminus owner miyagawa commented Mar 6, 2011 Did XML::SAX already exist in your perl?

Because whomever created the RPMs you're using made it that way there is no such cross dependency on CPAN. BEGIN failed--compilation aborted at t/13int_ent.t line 3. I also had this same problem with XML::LibXML and just tested XML::SAX::Expat and same problem. cpanminus owner miyagawa commented Mar 6, 2011 I can't reproduce the XML::SAX error on perl 5.12.3 on Mac OS X.

ok t/11sax1multiclass.t .... sys-devel/gettext) sys-devel/gcc-4.5.3-r1 (nls ? Compilation failed in require at xml.pl line 7. How do I handle this?

Here is an example: 1. BEGIN failed--compilation aborted at xml.pl line 7.It looks like the update to the XML::SAX package moved some stuff out to XML::SAX::Base. Files=14, Tests=106, 3 wallclock secs ( 0.09 usr 0.06 sys + 1.98 cusr 0.25 csys = 2.38 CPU) Result: PASS Can't locate XML/SAX.pm in @INC (@INC contains: /Users/yi/.perl5/perlbrew/perls/p512/lib/site_perl/5.12.3/darwin-2level /Users/yi/.perl5/perlbrew/perls/p512/lib/site_perl/5.12.3 /Users/yi/.perl5/perlbrew/perls/p512/lib/5.12.3/darwin-2level /Users/yi/.perl5/perlbrew/perls/p512/lib/5.12.3 http://stackoverflow.com/questions/25298111/cpan-installs-module-and-doesnt-see-it-after-cpan-database-issue ok t/04chfilter.t ..........

BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.12.4/XML/SAX.pm line 18. BEGIN failed--compilation aborted at /usr3/richardt/XML-SAX-0.12/blib/lib/XML/SA X/PurePerl.pm line 20. t/11xmldecl2.....dubious Test returned status 2 (wstat 512, 0x200) DIED. Register. 01-22-2012 #1 frank56 View Profile View Forum Posts Private Message View Articles Linux Newbie Join Date Aug 2009 Posts 156 Unable to emerge /app-text:docbook2X-0.8.8-r2 during world update I keep running

sys-devel/gettext) net-libs/gtk-vnc-0.4.3-r1 (sys-devel/gettext) net-libs/webkit-gtk-1.4.3-r200 (sys-devel/gettext) net-misc/wget-1.12-r3 (nls ? It did but i deleted it with pm-uninstall first. share|improve this answer answered Oct 18 '14 at 17:19 Andrey 112 When you change to 'root' user, be sure to ALWAYS use 'su - root' from you own user Compilation failed in require at t/10xmldecl1.t line 3.

ok All tests successful. http://scriptkeeper.net/cannot-locate/cannot-locate-to-any-english.html Execute bash script from vim Can dispel magic end a darkness spell? Try rebuilding XML-LibXML. cpanminus owner miyagawa commented Mar 6, 2011 Why did you not paste the whole build.log in the first place?

ok t/01simpledriver.t ...... done! >>> Verifying ebuild manifests >>> Emerging (1 of 1) dev-perl/XML-LibXML-1.900.0 * XML-LibXML-1.90.tar.gz RMD160 SHA1 SHA256 size ;-) ... [ ok ] >>> Unpacking source... >>> Unpacking XML-LibXML-1.90.tar.gz to /var/tmp/portage/dev-perl/XML-LibXML-1.900.0/work >>> BEGIN failed--compilation aborted. * Update Parser: remove XML::LibXML::SAX failed * Update Parser: add XML::LibXML::SAX::Parser Can't locate XML/SAX/Exception.pm in @INC (@INC contains: /etc/perl /usr/lib/perl5/site_perl/5.12.4/i686-linux-debug /usr/lib/perl5/site_perl/5.12.4 /usr/lib/perl5/vendor_perl/5.12.4/i686-linux-debug /usr/lib/perl5/vendor_perl/5.12.4 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.12.4/i686-linux-debug /usr/lib/perl5/5.12.4 /usr/local/lib/site_perl Check This Out Compilation failed in require at t/15element.t line 3.

Create A New User Node Status? Not the answer you're looking for? All the same, XML::SAX::Base is looking like a more and more necessary package for some of the stuff that's in the official repos. --James Offline #4 2011-10-10 11:58:36 giovanni Developer From:

make: *** [install_sax_pureperl] Error 2 make: *** Waiting for unfinished jobs.... -> FAIL Installing XML::SAX failed.

o checking whether we are using the GNU C compiler... sys-devel/gettext) sys-libs/glibc-2.14.1-r2 (nls ? sys-devel/gettext) sys-process/psmisc-22.14 (nls ? Actually, the first might've been right on the money, but my hiragana's a bit ropey … make sure you've got your system up to date with apt-get or aptitude.

Nodes You Wrote Super Search List Nodes By Users Newest Nodes Recently Active Threads Selected Best Nodes Best Nodes Worst Nodes Saints in our Book Leftovers? This was the first time I used perl-cleaner. sys-devel/gettext) sys-apps/man-1.6f-r4 (nls ? http://scriptkeeper.net/cannot-locate/cannot-locate-text-csv-pm.html Compilation failed in require at /usr3/richardt/XML-SAX-0.12/blib/lib/XML/SAX.pm line 147.

yes configure: creating ./config.status config.status: creating Makefile config.status: creating charmaps/Makefile config.status: creating dtd/Makefile config.status: creating xslt/Makefile config.status: creating xslt/common/Makefile config.status: creating xslt/common/text/Makefile config.status: creating xslt/man/Makefile config.status: creating xslt/texi/Makefile config.status: creating xslt/documentation/Makefile Sign in to comment Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. ok t/03chdriver.t .......... BEGIN failed--compilation aborted. * Update Parser: remove XML::LibXML::SAX::Parser failed * Update Parser: remove XML::LibXML::SAX Can't locate XML/SAX/Exception.pm in @INC (@INC contains: /etc/perl /usr/lib/perl5/site_perl/5.12.4/i686-linux-debug /usr/lib/perl5/site_perl/5.12.4 /usr/lib/perl5/vendor_perl/5.12.4/i686-linux-debug /usr/lib/perl5/vendor_perl/5.12.4 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.12.4/i686-linux-debug /usr/lib/perl5/5.12.4 /usr/local/lib/site_perl

ok t/16gethandlers.t ....... sys-devel/gettext) sys-apps/shadow-4.1.4.3 (nls ? They are installed correctly and not show up in the list after. You signed in with another tab or window.

Compilation failed in require at t/14encoding.t line 7. ok t/13handlerswitch.t ..... sys-devel/gettext) x11-terms/gnome-terminal-2.32.1 (sys-devel/gettext) x11-themes/gnome-backgrounds-3.2.0 (sys-devel/gettext) x11-themes/gnome-icon-theme-3.2.1.2 (sys-devel/gettext) x11-themes/gnome-themes-2.32.1-r1 (sys-devel/gettext) x11-themes/gnome-themes-standard-3.0.2 (sys-devel/gettext) x11-themes/sound-theme-freedesktop-0.7 (sys-devel/gettext) x11-wm/metacity-2.30.3 (sys-devel/gettext) I am thinking gettext and doc, are both text applications/entities, that might be why excluding the ok t/10xmldecl1.t ...

And my filesystem is the standard case-insensitive HFSJ with no FileVault or anything else. All whitespace is non-significant. y commented Mar 6, 2011 I have a vanilla perlbrewed install (perlbrew install perl-5.12.3 -as p512). For example, you may wish for a parser that supports validation via a DTD.

I had to switch to root any time, I was installing any module. BEGIN failed--compilation aborted at db2x_texixml line 2147. How Did The Dred Scott Decision Contribute to the Civil War?