Home > Cannot Load > Mysql Gem Windows

Mysql Gem Windows

Contents

I tried DBI, that didn't work. See http://guides.rubygems.org/command-reference/#gem-uninstall about uninstalling command. This could take a while... I do not use Windows but like in Linux/BSD you'll need install mysql development files (headers, libs) before, so extension library can be successfuly compiled. Source

yes checking for mysql_query() in -lmysqlclient... asked 3 years ago viewed 1488 times Upcoming Events 2016 Community Moderator Election ends Nov 22 Related 20Ruby: mysql2-Gem not working (Mac OS X Snow Leopard, Ruby 1.9.2)507`require': no such file Baden Württemberg Ticket usage Is it ethical for a journal to cancel an accepted review request when they have obtained sufficient number of reviews to make a decision? asked 2 years ago viewed 6010 times active 1 year ago Upcoming Events 2016 Community Moderator Election ends Nov 22 Related 383Error installing mysql2: Failed to build gem native extension3Rails 3 http://stackoverflow.com/questions/20693908/cannot-load-such-file-mysql-mysql-api

Mysql Gem Windows

My AccountSearchMapsYouTubePlayNewsGmailDriveCalendarGoogle+TranslatePhotosMoreShoppingWalletFinanceDocsBooksBloggerContactsHangoutsEven more from GoogleSign inHidden fieldsSearch for groups or messages Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. We recommend upgrading to the latest Safari, Google Chrome, or Firefox. I don't even remember that working remotely. Register here.

Now it will work fine. This could take a while.. Also, it looks you have rake version 10.1.1 installed, while required is 10.0.3. Ruby Mysql2 Example current community chat Stack Overflow Meta Stack Overflow your communities Sign up or log in to customize your list.

share|improve this answer answered Aug 10 '15 at 1:52 Raphael Cangucu 7112 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Cannot Load Such File Mysql No registration required! If I receive written permission to use content from a paper without citing, is it plagiarism? http://stackoverflow.com/questions/15301492/mysql-rb6in-r-equire-cannot-load-such-file-mysql-mysql-api-loaderror Hyper Derivative definition.

I even installed DBI gem, and even that doesnt work.. Install mysql2: gem install mysql2 -- '--with-mysql-lib="D:\php\MySQL-5.0.83\bin" --with-mysql-include="D:\php\MySQL-5.0.83\include"' The active record script will be like this: require 'rubygems' require 'active_record' ActiveRecord::Base.establish_connection( :adapter=> "mysql2", :host => "localhost", :database=> "test", :username => 'root', yes checking for rb_thread_blocking_region()... yes checking for mysql_query() in -lmysqlclient...

Cannot Load Such File Mysql

What is the total sum of the cardinalities of all subsets of a set? PHP regular expression C++ ? Mysql Gem Windows Category PHP ? Cannot Load Such File Mysql2 Sign in to comment Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc.

Passing parameters to boilerplate text A different way to handle Microsoft Exchange emails The cost of switching to electric cars? this contact form I love Ruby, and after years I have decided to get a project going. Oracle Terms PL/SQL MySQL MongoDB H2 Database Default Javascript Java ? Make sure that the adapter in config/database.yml is valid. Ruby Mysql Gem

Report post Edit Delete Reply with quote Re: Having Problem with MySQL Connectivity in Ruby. Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=C:/Ruby200/bin/ruby --with-mysql-dir --without-mysql-dir --with-mysql-include --without-mysql-include=${mysql-dir}/include --with-mysql-lib --without-mysql-lib=${mysql-dir}/ --with-mysql-config --without-mysql-config --with-mysql-dir --without-mysql-dir --with-mysql-include --without-mysql-include=${mysql-dir}/include --with-mysql-lib --without-mysql-lib=${mysql-dir}/ --with-mysqlclientlib --without-mysqlclientlib --with-mlib You have already activated rake 10.1.1, but your Gemfile requires rake 10.0.3. have a peek here So I just pasted your code in to Command however this was the result: ERROR: Error installing mysql2: ERROR: Failed to build gem native extension. –user2942719 Dec 20 '13 at 0:11

How to react? more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed mysql ruby-on-rails ruby ruby-on-rails-3 share|improve this question edited Dec 20 '13 at 0:16 Justin Wood 3,58321230 asked Dec 19 '13 at 23:49 user2942719 1 try gem install mysql2 -- --with-mysql-dir=c:\RailsInstaller\Ruby1.9.3\bin

no checking for mysql_query() in -lmysqlclient...

require 'rubygems' require 'mysql' db = Mysql.new('localhost', 'root', 'pass', 'test') The error messages. Tools Vim ©2016 makble.com To use Google Groups Discussions, please enable JavaScript in your browser settings, and then refresh this page. . no checking for main() in -lnsl... Now I did what the gem required by copying the file it needed into the directory....

Jason Steinbach (rubyjason) on 2014-05-23 23:40 Ok I installed the connector, and tried to reinstall the mysql gem. Thanks! Join them; it only takes a minute: Sign up Why does Rails say “cannot load such file mysql/mysql_api”? Check This Out C:/Sites/todo/config/boot.rb:6:in ' C:/Sites/todo/config/application.rb:1:in ' C:/Sites/todo/Rakefile:4:in `' (See full trace by running task with --trace) –user2942719 Dec 23 '13 at 20:34 I hope you tried bundle exec

First Catch Bonus My cat sat down on my laptop, now the right side of my keyboard types the wrong characters SMS verification, is it secure? Best way to remove old paint from door hinges How can I declare independence from the United States and start my own micro nation? more hot questions question feed default about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation You signed out in another tab or window.

Building native extensions. How to decide between PCA and logistic regression? no checking for mysql_query() in -lmysqlclient... Macro Concurrency Eclipse Maven Java File operation Java compiler error Graphics ?

David Unric (dunric) on 2014-05-22 23:07 It looks like mysql gem was improperly installed.