Home > Cannot Load > Cannot Load /usr/libexec/apache2/libphp5.so

Cannot Load /usr/libexec/apache2/libphp5.so

Sign in to comment Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. Thanks for the good work. otool -L /usr/local/Cellar/php53/5.3.16/libexec/apache2/libphp5.so otool -L /usr/local/opt/libxml2/lib/libxml2.2.dylib annelyze commented Sep 7, 2012 http://annelyze.be/otool.png and /usr/local/opt/libxml2 is a symlink to the 2.9.0 version of libxml. Thoughts? have a peek at this web-site

It'd be worth checking all the chained Apache config files to see the both these directives and testing by commenting out (# in front). However, don't be tempted by this approach! In the second blog post in this two-post series, we will cover MySQL, Apache virtual hosts, APC caching, and Xdebug installation. Also in morning I installed phpunit httpd: Syntax error on line 170 of /private/etc/apache2/httpd.conf: Cannot load /usr/local/opt/php56/libexec/apache2/libphp5.so into server: dlopen(/usr/local/opt/php56/libexec/apache2/libphp5.so, 10): Symbol not found: _ldap_control_find\n Referenced from: /usr/local/opt/php56/libexec/apache2/libphp5.so\n Expected in: /System/Library/Frameworks/LDAP.framework/Versions/A/LDAP\n https://github.com/Homebrew/homebrew-php/issues/763

Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. After that, I am getting this error!! thomasmeeus commented Sep 7, 2012 @phoenixsong6 thx, testing it out at the moment !

But then my current sites were not working. How to make my logo color look the same in Web & Print? In particular you will need to change the following: 2.2 configuration: Order allow,deny Allow from all 2.4 configuration: Require all granted share|improve this answer answered Oct 20 '14 at 11:45 John Apache is controlled via the apachectl command so some useful commands to use are: $ sudo apachectl start $ sudo apachectl stop $ sudo apachectl -k restart The -k will force

annelyze commented Sep 7, 2012 @phoenixsong6 still the same error I'm afraid. annelyze commented Sep 4, 2012 I'm having about the same problem with php 5.3.16. I tried to set the necessary settings in httpd.conf file. https://github.com/Homebrew/homebrew-php/issues/2446 I do have a /usr/local/opt/postgresql directory.

You can test the other PHP versions by commenting the LoadModule ... I have apache 2.4.23_1 installed using homebrew. (mac osx Mavericks) The original error is: httpd: Syntax error on line 157 of /usr/local/apache-2.4.9/conf/httpd.conf: Cannot load /usr/local/opt/php56/libexec/apache2/libphp5.so into server: dlopen(/usr/local/opt/php56/libexec/apache2/libphp5.so, 10): Symbol not Removing the # sign as suggested by Nuttyx above will load the Apple version of php (5.5.14). Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 96 Star 2,185 Fork 623 Homebrew/homebrew-php Code Issues 35 Pull requests 21 Projects

Please help. Sign up for free to join this conversation on GitHub. https://github.com/Homebrew/homebrew-php/issues/1229 albygnagna commented Jun 27, 2015 Got the same problem updating xcode and all brew formulas. You signed out in another tab or window. javian commented Aug 1, 2016 @tarunhere @peemoRoyal - if you are on Yosemite you need to build php from source and not install the bottle since its currently broken.

Already have an account? Check This Out The first step is to update Brew so that it gets a list of available updates: $ brew update This will spit out a list of available updates, and any deleted coredumperror commented Mar 30, 2016 Sadly, the --with-homebrew-apxs flag causes a compile error regarding freetype.h, as mentioned in several other issues on here. You must migrate to httpd24. 747823 commented Jun 29, 2016 Same problem here.

Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. The formula is looking for the /usr/local/opt directory for the pg_config information. Congratulations! Source javian commented Mar 31, 2016 Ah yes, I saw you commented on #3014 which needs to be resolved for php53 to compile.

Just something to try. We recommend upgrading to the latest Safari, Google Chrome, or Firefox. I'm using PHP 5.5.18 and would be better to keep the same version avoiding downgrade to PHP5.4.

Reload to refresh your session.

BillGoldsmith commented Feb 16, 2015 Here's what I see on my system: Mac-sd:~ bill$ ls -l which pg_config lrwxr-xr-x 1 bill admin 40 Dec 30 18:07 /usr/local/bin/pg_config -> ../Cellar/postgresql/9.4.0/bin/pg_config Postgres was It's quite IMPORTANT at this stage to fully stop your Apache sever, and start it again. I have reinstalled httpd22 (Apache 2.2) from homebrew but the error is still there. In this example we are just including Apache support via --with-apache to build the required PHP modules for Apache. $ brew install php55 --with-apache $ brew unlink php55 $ brew install

Nothing smells to shake it off. Would appreciate your comments/guide. This is the folder where Apache looks to serve file from. http://scriptkeeper.net/cannot-load/cannot-load-usr-libexec-apache2-mod-dav-svn-so.html This is a simple process, but you need to launch your Terminal (/Applications/Utilities/Terminal) application and then enter: ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)" Just follow the terminal prompts and enter your password