Home > Cannot Load > Cannot Load /usr/lib/apache2/modules/libphp5.so

Cannot Load /usr/lib/apache2/modules/libphp5.so

ApportVersion: 2.10.2-0ubuntu3 Architecture: amd64 Date: Thu Jul 18 13:19:25 2013 DuplicateSignature: package:apache2:2.4.4-6ubuntu4:subprocess installed post-installation script returned error exit status 1 ErrorMessage: subprocess installed post-installation script returned error exit status 1 InstallationDate: Try 'apt-get -f install' with no packages (or specify a solution). asked 2 years ago viewed 39217 times active 4 months ago Linked 1 How to resolve “The apache2 configtest failed”? 0 I can't restart apache Related 1Why do apache2 upgrades remove Not the answer you're looking for? http://scriptkeeper.net/cannot-load/cannot-load-opt-local-apache2-modules-libphp5-so.html

failed! Probably yes, it is missing, so we go further on this branch. First, check the installation status of the PHP5 module package : [email protected]:~$ dpkg -l |grep libapache2-mod-php5 ii libapache2-mod-php5 5.5.9+dfsg-1ubuntu4.3 amd64 server-side, HTML-embedded scripting language (Apache 2 module) If the result is Output of config test was: apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: cannot open shared object file: http://askubuntu.com/questions/536128/apache2-start-error-when-using-php5-module-ubuntu-server

Select 2D data in a certain range Did a thief think he could conceal his identity from security cameras by putting lemon juice on his face? Try an apt-get --reinstall install libapache2-mod-php5. locate libphp5.so returns what? –Prix Sep 22 '13 at 22:54 ls -la /usr/lib/apache2/modules/libphp5.so returns ls: Zugriff auf /usr/lib/apache2/modules/libphp5.so nicht möglich: Datei oder Verzeichnis nicht gefunden (Access to /usr/lib/apache2/modules/libphp5.so not

The Apache error log may have more information. Do Morpheus and his crew kill potential Ones? That's why you get the error message above. Not the answer you're looking for?

When I start apache2 everything is fine, but when enabling php5 module and restarting apache2 I get this error: ERROR: *** Restarting web server apache2 [fail] * The apache2 configtest failed. Trying to reinstall libapache5 however lead to sudo apt-get install libapache2-mod-php5 Reading package lists... more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science Thanks man. –Joserex65 Oct 12 '14 at 12:47 add a comment| up vote 4 down vote I solved it by running sudo apt install libapache2-mod-php and it installed the proper version

How Did The Dred Scott Decision Contribute to the Civil War? Heeter Heeter, Mar 13, 2012 #4 sjau Local Meanie Moderator uninstall and reinstall php5.... Not the answer you're looking for? y Get:1 http://archive.ubuntu.com/ubuntu/ saucy/main libapache2-mod-php5 i386 5.5.1+dfsg-1ubuntu1 [2,821 kB] Get:2 http://archive.ubuntu.com/ubuntu/ saucy/main apache2-mpm-prefork i386 2.4.4-6ubuntu5 [1,438 B] Get:3 http://archive.ubuntu.com/ubuntu/ saucy/main apache2-utils i386 2.4.4-6ubuntu5 [83.2 kB] Fetched 2,906 kB in 55s (52.3

How to gain confidence with new "big" bike? http://serverfault.com/questions/647876/libphp5-so-is-missing-dependency-problems Ubuntu Logo, Ubuntu and Canonical Canonical Ltd. What is with the speech audience? My cat sat down on my laptop, now the right side of my keyboard types the wrong characters more hot questions question feed about us tour help blog chat data legal

For details and our forum data attribution, retention and privacy policy, see here current community blog chat Super User Meta Super User your communities Sign up or log in to customize Check This Out After this operation, 110 kB of additional disk space will be used. Why are LEDs in my home unaffected by voltage drop? But I bet there are other issues if it is now running php7.0 where as it was before running php5.

Do Morpheus and his crew kill potential Ones? Starting Apache leads to the error message sudo service apache2 restart apache2: Syntax error on line 244 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: Please help me as I don't want to loose all the previous configuration I have. Source This may be considered preferable in case of a network interruption (and because it requires, in a sense, fewer steps).

Newer Than: Search this thread only Search this forum only Display results as threads Useful Searches Recent Posts More... Comment on this change (optional) Email me about changes to this bug report apache2 (Ubuntu) Edit Fix Released High Robie Basak Edit You need to log in to change this Debian bug tracking system administrator .

In your place I removed some problematic packages (dpkg --purge for induvidual packages, or apt-get --purge remove to remove packages with all of their dependencies), and then tried to reinstall them.

Toggle useless messagesView this report as an mbox folder, status mbox, maintainer mbox Report forwarded to [email protected], Debian PHP Maintainers : Bug#810041; Package libapache2-mod-php7.0. (Tue, 05 Jan 2016 21:45:05 GMT) Full It wants to install the package udev but ends up with an error insserv: script apache: service apache2 already provided! After reinstalling *php5* from unstable and purging those OS> packages, the files will be gone. Debian Bug tracker #717343 URL: The information about this bug in Launchpad is automatically pulled daily from the remote bug.

Changed in apache2 (Ubuntu Saucy): status: In Progress → Fix Released See full activity log To post a comment you must log in. Stay logged in Sign up now! Mark as duplicate Convert to a question Link a related branch Link to CVE Remove CVE link Duplicates of this bug Bug #1202769 Bug #1202814 Bug #1203118 Bug #1204024 You are have a peek here Copy sent to Debian PHP Maintainers . (Sat, 09 Jan 2016 06:03:04 GMT) Full text and rfc822 format available.

philinux (philcb) wrote on 2013-07-18: #4 Already run fix broken many times from terminal synaptic and tried aptitude. Jeremy Bicha (jbicha) on 2013-07-19 summary: - package apache2 2.4.4-6ubuntu4 failed to install/upgrade: subprocess- installed post-installation script returned error exit status 1+ apache2 2.4.4-6ubuntu4 failed to upgrade: Cannot load+ /usr/lib/apache2/modules/libphp5.so into You may try commenting out the offending line, 244 of apache.conf, and see whether your system can get by this way (but I doubt it). share|improve this answer answered Jan 29 at 1:49 rooby 1011 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign up

Now I'm not sure if the changes apache2.conf actually caused the problem... How can I get my Apache running again? The time now is 12:47 AM. Can clients learn their time zone on a network configured using RA?

I changed the line to AllowOverride None again but the problem remains. The apache2 error.log does not contain any information. See also the AllowOverride # directive. # AccessFileName .htaccess # # The following lines prevent .htaccess and .htpasswd files from being # viewed by Web clients. # Require all step could even be skipped.) –Eliah Kagan Sep 6 '14 at 0:54 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google

Remaining changes: - debian/{control, rules}: Enable PIE hardening. - debian/{control, apache2.install, apache2-utils.ufw.profile,
apache2.dirs}: Add ufw profiles. - debian/apache2.py, debian/apache2-bin.install: Add apport hook. - debian/control, debian/config-dir/mods-available/ssl.conf, debian/ask-for-passphrase, debian/apache2.install: What was Stan Lee's character reading on the bus in Doctor Strange How safe is 48V DC? I tried some troubleshooting and followed a form where it was advised to enable mod php5, so I did a2enmod php5 and tried to restart apache. Browse other questions tagged apache-2.2 debian debian-wheezy or ask your own question.

But the problem is essentially the same: both of you want to fix the inconsistent state of a debian/ubuntu system. If works, you are ready. Here you can find my other answer, which can provide useful commands to you, although the original question was different: he wanted to fix a failed upgrade, you want to fix Creating symlink for a file on Windows 7 gives error How to decide between PCA and logistic regression?

more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed