Home > Cannot Load > Cannot Load Awt Toolkit Opensuse

Cannot Load Awt Toolkit Opensuse

note: this PC has JRE 1.4 & JDK 1.5..... creating: JMF-2.1.1e/ creating: JMF-2.1.1e/bin/ inflating: JMF-2.1.1e/bin/jmfinit inflating: JMF-2.1.1e/bin/jmfregistry inflating: JMF-2.1.1e/bin/jmstudio creating: JMF-2.1.1e/doc/ inflating: JMF-2.1.1e/doc/attributions.html inflating: JMF-2.1.1e/doc/formats.html inflating: JMF-2.1.1e/doc/readme.html creating: JMF-2.1.1e/lib/ inflating: JMF-2.1.1e/lib/libjmcvid.so inflating: JMF-2.1.1e/lib/libjmdaud.so inflating: JMF-2.1.1e/lib/libjmfjawt.so inflating: JMF-2.1.1e/lib/libjmg723.so inflating: JMF-2.1.1e/lib/libjmgsm.so inflating: How did I find this answer? Once I told it to run scripts then the shortcut method works just right. "Linux provides freedom, problem is most users don't know what it is or how to use it." Source

Reply With Quote 06-Jun-2014,00:49 #2 buckesfeld View Profile View Forum Posts View Blog Entries View Articles Global Moderator Join Date Mar 2008 Location Bochum, Germany Posts 3,656 Re: Installing Minecraft on Are you new to LinuxQuestions.org? I tried installing jmf-2_1_1e-linux-i586.bin on my RedHat 9 machine. Results 1 to 6 of 6 Thread: Installing Minecraft on OpenSUSE 13.1 Thread Tools Show Printable Version Subscribe to this Thread… Display Linear Mode Switch to Hybrid Mode Switch to Threaded Go Here

When I try to execute a java program using the java ProgramName command, I get this error Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit at java.awt.Toolkit.getDefaultToolkit(libgcj.so.7) at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(libgcj.so.7) If you need to reset your password, click here. Advertisements Latest Threads Google analytics doesn't work with google forms NewCureForAnger posted Nov 3, 2016 at 10:03 PM Code or Concatenation tina miller posted Oct 28, 2016 Is this possible? You'll be able to ask questions about coding or chat with the community and help others.

I created a short script launching it, that one can be clicked. > and running "java -jar Minecraft.jar" in a > Terminal only returns: > > > Code: > -------------------- > You don't have Sun's Java set up properly... Join Date Jun 2006 Beans 326 DistroUbuntu 8.04 Hardy Heron Re: Cannot load AWT toolkit ?? In KDE, you can right click it, open with, find "bash" and tell it to remember the association.

May be easiest to install OpenJDK if that is the only one opensuse provides packages for. Just click the sign up button to choose a username and then you can ask your own questions on the forum. Search this Thread 05-12-2006, 07:42 PM #1 artemis8543 LQ Newbie Registered: Apr 2006 Distribution: Ubuntu 6.06 Posts: 3 Rep: java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit Hi, I just started https://ubuntuforums.org/showthread.php?t=388226 So it was using the GNU classpath I think.

I downloaded the nightly JME zip and when I run the demos I get:[email protected]:/opt/jme$ ./runme.shException in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit mojomonk 2006-06-13 23:56:22 UTC #2 Hmmm well, Thanks a lot artemis8543 View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by artemis8543 05-13-2006, 01:58 PM #2 mrcheeks Senior Member What does "java -version" say? I ran it based on the information I found here : http://www.unixmen.com/install-java-openususe-12-3-32/ Didn't know about adding the "-jar" to the command line, I'll have to give that a try. "Linux provides

SMS verification, is it secure? https://lists.debian.org/debian-java/2006/11/msg00009.html asked 3 years ago viewed 25847 times active 3 years ago Upcoming Events 2016 Community Moderator Election ends Nov 22 Linked 25 Unable to run java gui programs with ubuntu 17 Check the repo and see if you have this installed, and or check for an update. mona is not in the sudoers file.

In KDE, you can right click it, open with, find "bash" and tell it to remember the association. http://scriptkeeper.net/cannot-load/cannot-load-awt-toolkit-minecraft.html Robert Mark Bram Guest Howdy All! What am I doing wrong/haven't I done? Home Categories FAQ/Guidelines Terms of Service Privacy Policy Powered by Discourse, best viewed with JavaScript enabled   Home Forum Wiki JavaDoc Source code How to get answers Math for Dummies Scenegraph

Now I get to the launcher, but when I log in I get: asdf Exception in thread "Thread-3" java.lang.UnsatisfiedLinkError: /home/snork/.minecraft/bin/natives/liblwjgl.so: /home/jrobb/.minecraft/bin/natives/liblwjgl.so: wrong ELF class: ELFCLASS32 (Possible cause: architecture word width mismatch) Note: its a simple application, with just a few buttons, with standard layouts, & no fancy outside libraries/jars. >>>java -jar SBWithMain.jar Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit It looks like everything points to libgcj.so.13 which is a Java Runtime Library for gcc. have a peek here These Aren't Roasted!

Removing libgcj7-jar ... Does anybody know how i might fix it ? I have tried double-clicking the Minecraft.jar file and it opens in the archiver, but when I try and "Open with " Java I cannot find Java in the list of programs

Please visit this page to clear all LQ-related cookies.

Advanced Search

Forum English Get Technical Help Here Games Installing Minecraft on OpenSUSE 13.1 Welcome! About Us The Coding Forums is a place to seek help and ask questions relating to coding and programming languages. Newer Than: Search this thread only Search this forum only Display results as threads Useful Searches Recent Posts More... Thanks for the afford!

vBulletin 2000 - 2016, Jelsoft Enterprises Ltd. Still no joy. sudo apt-get install libxtst6:i386 did the trick for me. http://scriptkeeper.net/cannot-load/cannot-load-awt-toolkit.html User contributions on this site are licensed under the Creative Commons Attribution Share Alike 4.0 International License.

Join Date Jun 2006 Beans 326 DistroUbuntu 8.04 Hardy Heron Re: Cannot load AWT toolkit ?? LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit User Name Remember Me? I might even reinstall them some time...